Section réservée à la migration depuis Fireboard ou depuis les versions précédant Kunena 2.0 et autres forums

Migration K5>K6 : problèmes avec la base de données

Plus d'informations
15 Juil 2023 11:48 - 15 Juil 2023 12:45 #1 par Luigi_B
Rebonjour à tous.

J'avais tenté la migration J3+K5 vers J4+K6 avec des petites difficultés l'été 2022 dernier mais j'avais dû renoncer en cours de route. Je m'y attelle de nouveau cet été.

La migration J3.10.12+K5 vers J4.3.3+K6.1.2 semble avoir fonctionné, la base de données a été mise à jour, les messages sont accessibles etc. et l'esthétique épurée par défaut du nouveau template Kunena est très agréable.

J'ai néanmoins deux problème importants :

- Dans le dashboard de Kunena, ce message :
Code:
1054 Unknown column 'checked_out_time' in 'where clause'

Ou quand je veux lancer les diagnostics
Code:
1054 Unknown column 'a.parentid' in 'where clause'

- Beaucoup plus embêtant : les catégories de mon K5. C'est comme si elles n'étaient plus reconnues dans K6. Dans le backend, plus de trace. Dans le frontend elles n'apparaissent plus dans la page d'accueil, même si on les retrouve plus ou moins dans le chemin des fils de discussion (je dis plus ou moins car les grandes catégories principales semblent avoir disparu). Et quand je clique sur la catégorie, les sous-catégories n'apparaissent pas non plus que les fils.

J'ai fait un tour dans la base SQL (#_kunena_categories) : les catégories sont bien là. L'arborescence de mes 78 catégories semble bien conservée.

Bref je suis perplexe. Je vais voir ce que je peux avoir comme idées, mais si vous avez des suggestions...

Configuration
Dernière édition: 15 Juil 2023 12:45 par Luigi_B.

Veuillez vous connecter ou vous enregistrer pour rejoindre la conversation.

Plus d'informations
15 Juil 2023 12:59 - 15 Juil 2023 13:13 #2 par Luigi_B
J'ai trouvé une partie de la réponse, une erreur dans le titre d'une entrée dans #_kunena_categories. J'ai lancé la requête :
Code:
ALTER TABLE `joomku_kunena_categories` CHANGE `parent_id` `parentid` INT(11) NULL DEFAULT '0';

Et les catégories sont réapparues.

J'ai pu lancer un diagnostic et réparer presque toutes les erreurs.

Mais j'ai toujours le problème du dashboard.

 
Dernière édition: 15 Juil 2023 13:13 par Luigi_B.

Veuillez vous connecter ou vous enregistrer pour rejoindre la conversation.

Plus d'informations
15 Juil 2023 18:32 - 17 Juil 2023 11:08 #3 par Luigi_B
J'ai désinstallé et réinstallé K6 : le tableau de bord est apparu (mais en anglais lorsque je clique sur un sous-menu du composant).

Pendant un certain temps j'ai rencontré des messages d'erreur en voulant éditer des messages, répondre ou créer. Les actions sont néanmoins réalisées

Edition, réponse ou création d'un message :
Code:
danger field 'params' doesn't have a default value

S'agissant de la création, l'écran continue d'afficher un message vide mais le message a bien été créé.

Je soupçonne un nouveau problème dans la base.


 
Dernière édition: 17 Juil 2023 11:08 par Luigi_B.

Veuillez vous connecter ou vous enregistrer pour rejoindre la conversation.

Plus d'informations
17 Juil 2023 10:10 - 17 Juil 2023 10:12 #4 par failrOn
Bonjour,

Aprés l'installation de Kunena, quand vous allez sur le dashboard de Kunena c'est à ce moment-là qu'il fait la mise à jour des tables de Kunena mais à priori cela ne s'est pas fait chez vous

Il y a qu'une colonne checked_out_time qui est dans la table #__kunena_categories

Pour soutenir le projet Kunena : soutenir via le système de sponsor de github
Dernière édition: 17 Juil 2023 10:12 par failrOn.

Veuillez vous connecter ou vous enregistrer pour rejoindre la conversation.

Plus d'informations
17 Juil 2023 11:06 - 17 Juil 2023 11:08 #5 par Luigi_B
Bonjour FailrOn et merci.

Il y a qu'une colonne checked_out_time qui est dans la table #__kunena_categories

Que veux-tu dire ? 

Attention : Spoiler !


J'observe aussi que l'édition de message est erratique. Parfois le message à éditer est vide, parfois je peux éditer mais à l'enregistrement j'ai ce message :
Code:
danger Impossible de sauvegarder le message: L'adresse de courriel n'est pas valide!
Dernière édition: 17 Juil 2023 11:08 par Luigi_B.

Veuillez vous connecter ou vous enregistrer pour rejoindre la conversation.

Plus d'informations
17 Juil 2023 11:34 #6 par failrOn

J'ai néanmoins deux problème importants :

- Dans le dashboard de Kunena, ce message :
Code:
1054 Unknown column 'checked_out_time' in 'where clause'
Je parlais par rapport à cette erreur, mais sur votre capture d'écran de votre dernier message cette colonne est là

Pour l'erreur sur l'adresse de courriel, auriez-vous activé dans les paramètres de Kunena l'option qui fait que le courriel est requis lors des réponses ?

Pour soutenir le projet Kunena : soutenir via le système de sponsor de github

Veuillez vous connecter ou vous enregistrer pour rejoindre la conversation.

Modérateurs: lavstephtramber91failrOnScottuxdede17serge
Temps de génération de la page : 3.969 secondes
Propulsé par Kunena