Question [Résolu] "KunenaConfig not found"

Plus d'informations
09 Aoû 2022 18:21 - 11 Aoû 2022 00:17 #1 par Luigi_B
Premières tentatives pour migrer vers K6.

Dans Joomla 3.1, je désinstalle Kunena, je migre de Joomla 3.1 à 4.15 sans grande difficulté.  Mais dès que j'installe K6, en ligne ou à partir du fichier téléchargé :

0 Class "Kunena\Forum\Libraries\Config\KunenaConfig" not found


Et le reste de Joomla devient inaccessible (impossible d'avoir un log des erreurs...). :-/

Quelqu'un aurait-il une idée ?

 
Dernière édition: 11 Aoû 2022 00:17 par Luigi_B.

Veuillez vous connecter ou vous enregistrer pour rejoindre la conversation.

Plus d'informations
10 Aoû 2022 11:56 #2 par failrOn
Réponse de failrOn sur le sujet "KunenaConfig not found"
Bonjour,

vérifiez que le plugin système de Kunena s'est bien installé et est bien activé. Et vérifiez que les fichiers nécessaires à Kunena soient sous : libraries\kunena\src

Pour soutenir le projet Kunena : soutenir via le système de sponsor de github

Veuillez vous connecter ou vous enregistrer pour rejoindre la conversation.

Plus d'informations
10 Aoû 2022 17:46 - 10 Aoû 2022 18:36 #3 par Luigi_B
Réponse de Luigi_B sur le sujet "KunenaConfig not found"
Merci failrOn. Les fichiers semblent bien en place.

Je ne peux pas vérifier l'activation du plugin : le backend de Joomla est planté avec cette erreur.

Edit : j'ai testé avec une installation nouvelle de Joomla 4.15 et j'ai vu que le frontend était un peu différent, ce qui me laisse penser que ma migration Joomla a en partie échoué (bien que rien ne me l'indique). L'installation de Kunena comme extension nouvelle s'est passée sans problème.

Bref, l'hébergement n'est pas en cause (cf la question que je me posais sur la version de MySql ). C'est un début mais ça ne m'avance pas beaucoup.

 
Dernière édition: 10 Aoû 2022 18:36 par Luigi_B.

Veuillez vous connecter ou vous enregistrer pour rejoindre la conversation.

Plus d'informations
10 Aoû 2022 21:47 - 10 Aoû 2022 21:52 #4 par failrOn
Réponse de failrOn sur le sujet "KunenaConfig not found"
Pour vérifier que le plugin système de Kunena est bien présent c'est dans le dossier : \plugins\system\kunena

Dans la base données avec Phpmyadmin en faisant cette requête : 
SELECT * FROM `#__extensions` where name = 'plg_system_kunena';
vous regardez si la colonne "enabled" est bien sur 1

Si c'est bien le cas, ouvrez avec le bloc-notes le fichier : \administrator\cache\autoload_psr4.php, vous devriez voir ces lignes :
    'Kunena\\Forum\\Administrator\\' => [JPATH_ADMINISTRATOR . '/components/com_kunena/src'],
   'Kunena\\Forum\\Libraries\\' => [JPATH_LIBRARIES . '/kunena/src'],
    'Kunena\\Forum\\Plugin\\Kunena\\Altauserpoints\\' => [JPATH_PLUGINS . '/kunena/altauserpoints'],
    'Kunena\\Forum\\Plugin\\Kunena\\Community\\' => [JPATH_PLUGINS . '/kunena/community'],
    'Kunena\\Forum\\Plugin\\Kunena\\Comprofiler\\' => [JPATH_PLUGINS . '/kunena/comprofiler'],
    'Kunena\\Forum\\Plugin\\Kunena\\Easyprofile\\' => [JPATH_PLUGINS . '/kunena/easyprofile'],
    'Kunena\\Forum\\Plugin\\Kunena\\Easysocial\\' => [JPATH_PLUGINS . '/kunena/easysocial'],
    'Kunena\\Forum\\Plugin\\Kunena\\Finder\\' => [JPATH_PLUGINS . '/kunena/finder'],
    'Kunena\\Forum\\Plugin\\Kunena\\Gravatar\\' => [JPATH_PLUGINS . '/kunena/gravatar'],
    'Kunena\\Forum\\Plugin\\Kunena\\Joomla\\' => [JPATH_PLUGINS . '/kunena/joomla'],
    'Kunena\\Forum\\Plugin\\Kunena\\Kunena\\' => [JPATH_PLUGINS . '/kunena/kunena'],
    'Kunena\\Forum\\Plugin\\Quickicon\\Kunena\\' => [JPATH_PLUGINS . '/quickicon/kunena'],
    'Kunena\\Forum\\Plugin\\Sampledata\\Kunena\\' => [JPATH_PLUGINS . '/sampledata/kunena'],
    'Kunena\\Forum\\Plugin\\System\\Kunena\\' => [JPATH_PLUGINS . '/system/kunena'],
    'Kunena\\Forum\\Site\\' => [JPATH_SITE . '/components/com_kunena/src'],

Si vous ne voyez pas ces lignes supprimer le fichier autoload_psr4.php, en rechargeant le navigateur il vas se re-créer tout seul et doit comporter les lignes indiquées ci-dessus

Pour soutenir le projet Kunena : soutenir via le système de sponsor de github
Dernière édition: 10 Aoû 2022 21:52 par failrOn.

Veuillez vous connecter ou vous enregistrer pour rejoindre la conversation.

Plus d'informations
10 Aoû 2022 22:32 - 11 Aoû 2022 00:03 #5 par Luigi_B
Réponse de Luigi_B sur le sujet "KunenaConfig not found"
Merci failrOn.

Le dossier : \plugins\system\kunena semble bien exister avec son contenu : 3 fichiers + 1 répertoire "language" (?).

En revanche, dans PhpMyAdmin, pas de résultat : la ligne plg_system_kunena n'existe pas. Les lignes sont absentes de autoload_psr4.php. :-/
 
Dernière édition: 11 Aoû 2022 00:03 par Luigi_B.

Veuillez vous connecter ou vous enregistrer pour rejoindre la conversation.

Plus d'informations
10 Aoû 2022 22:45 #6 par failrOn
Réponse de failrOn sur le sujet "KunenaConfig not found"
Essayez de re-lancer l'installation de Kunena

Pour soutenir le projet Kunena : soutenir via le système de sponsor de github

Veuillez vous connecter ou vous enregistrer pour rejoindre la conversation.

  • Vous ne pouvez pas: Créer un nouveau sujet.
  • Vous ne pouvez pas: Répondre au sujet.
  • Vous ne pouvez pas: Éditer votre message.
Temps de génération de la page : 0.224 secondes
Propulsé par Kunena