Image dans lien de menu Kunena

Plus d'informations
11 Juil 2023 10:49 - 14 Juil 2023 08:16 #1 par Scottux
Bonjour,
Je ne parviens pas à mettre une image pour les liens de menus dans Kunena. Je suis sous Joomla 4.3.2 et Kunena 6.1.2.
Ca fonctionnait correctement sous Joomla 3.
Après enregistrement d'une image de lien de menu dans le back-end, j'ai cette erreur qui s'affiche en frontend :
Code:
[b]Rendering Error[/b] in layout [b]Widget/Menu[/b]: Cannot access protected property Joomla\CMS\Menu\MenuItem::$params in [b]/home/scottux/www/monsite/libraries/kunena/src/Layout/KunenaBase.php[/b] on line 182 Layout was rendered in [b]/home/scottux/www/monsite/libraries/kunena/src/Layout/KunenaLayout.php[/b] on line 165
Dernière édition: 14 Juil 2023 08:16 par Scottux. Raison: Passage sujet en résolu

Veuillez vous connecter ou vous enregistrer pour rejoindre la conversation.

Plus d'informations
13 Juil 2023 22:32 #2 par failrOn
Réponse de failrOn sur le sujet Image dans lien de menu Kunena
Bonjour,

Je viens de faire un correctif voir : github.com/Kunena/Kunena-Forum/commit/a1...8345fbd5fca7b6bc2323

Pour soutenir le projet Kunena : soutenir via le système de sponsor de github

Veuillez vous connecter ou vous enregistrer pour rejoindre la conversation.

Plus d'informations
14 Juil 2023 08:18 #3 par Scottux
Réponse de Scottux sur le sujet Image dans lien de menu Kunena
Bonjour et merci pour le correctif.
Maintenant, ça fonctionne parfaitement. Je passe le sujet en "Résolu".
Bonne journée.
 

Veuillez vous connecter ou vous enregistrer pour rejoindre la conversation.

Temps de génération de la page : 0.475 secondes
Propulsé par Kunena