Questions générales relatives à l'utilisation de Kunena

Migrer Kunena 5.0.13/Joomla 3.10 vers Joomla 4

Plus d'informations
20 Nov 2023 12:34 - 20 Nov 2023 12:35 #1 par lomart
Bonjour,

J'essaie de passer mon site en Joomla 4 ou plus si affinité
Tout se passe bien pour toutes les extensions, seul le forum Kunena 5.0.13 fait de la résistance.
Avant la mise à jour J4, j'ai fait, avec succès, les mises à jour 5.1.0, 5.1.19 et 5.2.7 pour Kunena. La 6.2 n'est pas possible.
Par sécurité, je désactive le plugin system Kunena avant l'update Joomla qui se passe bien.
Après réactivation du plugin, le tableau de bord de Kunena m'affiche : Class "KunenaProfiler" not found
J'ai tenté d'installer la 6.2.1, mais c'est impossible.

Si une âme charitable pouvait m'indiquer mon erreur. Existe-t-il une procédure/tuto quelque part ?

Merci d'avance
 
Dernière édition: 20 Nov 2023 12:35 par lomart.

Veuillez vous connecter ou vous enregistrer pour rejoindre la conversation.

Plus d'informations
21 Nov 2023 11:55 - 21 Nov 2023 11:57 #2 par failrOn
Bonjour,

La version 5.x n'étant pas compatible avec Joomla! 4.x, il y a une manipulation à faire.

Dans ce cas-là sous Joomla! 3.10 il faut désinstaller Kunena (avec les plugins de Kunena et modules) depuis Joomla!. Ensuite quand vous aurez fait la migration vers la 4.4, vous installez Kunena 6.2.1, à la fin de l'installation il vous redirige tout seul vers le panneau d'administration de Kunena et il fait la mise à jour des tables de Kunena. Si il ne vous redirige pas vers le panneau d'administration de Kunena il faut y aller pour qu'il fasse la mise à jour des tables.

Pour soutenir le projet Kunena : soutenir via le système de sponsor de github
Dernière édition: 21 Nov 2023 11:57 par failrOn.

Veuillez vous connecter ou vous enregistrer pour rejoindre la conversation.

Plus d'informations
21 Nov 2023 12:40 #3 par lomart
Merci beaucoup pour explication.
C'est la procédure que j'ai cherchée sans succès
Je teste cela et je reviens faire un retour
Encore merci

Veuillez vous connecter ou vous enregistrer pour rejoindre la conversation.

Plus d'informations
23 Nov 2023 07:06 #4 par lomart
Bonjour,

Merci pour votre solution qui fonctionne à merveille.

Il a juste fallu sous Joomla 3.10 que je fasse les mises à jour de la version 5.1.13 vers la version 5.2.7.
Ensuite, après la migration vers Joomla 4, j'ai pu installer la version 6.2.1

Encore merci pour votre support

Veuillez vous connecter ou vous enregistrer pour rejoindre la conversation.

Modérateurs: lavstephtramber91failrOnScottuxdede17serge
Temps de génération de la page : 0.778 secondes
Propulsé par Kunena